Post Tue Nov 13, 2012 12:02 pm

Alfa036h/BT5R3 AP connection issues

So I've had the issue of getting my 036h(rtl8187) to connect to the internet on BackTrack 5 R3 32-bit (both through vmware and hard install) and have only been able to connect to an AP maybe 3 times. Before anyone tells me what I am doing wrong know this: Its not in monitor mode when trying to connect to AP, ive tried the latest compat-wireless drivers as of the week of 11/12, I know the correct password, and yes this is my router I am testing for my own peace of mind :P So that being said, when I do try to connect to an AP, whether its wpa or wep, it wont allow me to obtain an IP. Depending on what WPA supplicant I use I can get different responses to a connection attempt, like Incorrect password or cannot obtain IP. Ive had pretty much no luck with this issue using WICD or NetworkManager as they both will just lock-up. Ive read forums galore since i ran into this problem and even tried a buncha different fixes (reloaded bt5r3 about 4 times on my computer to wipe the slate clean and try new fixes) and still havent come up with a full solution. I can inject and monitor mode works fine... I just cant connect to an AP!

I am no pro as far as Linux goes, just an enthusiast that loves to learn! That being said I will be monitoring this posting for the next week or 2 or until a solution is found! I'm sure I left some necessary information out so if any is needed to help come to a conclusion as to the cause of this, please feel free to let me know :D Appreciate any help you can toss my way!
Last edited by TheCharlesBronson on Tue Nov 13, 2012 3:02 pm, edited 1 time in total.