.

WARVOX WARDIALER HELP

<<

mosess

User avatar

Newbie
Newbie

Posts: 6

Joined: Tue Oct 09, 2012 8:04 am

Post Tue Oct 09, 2012 8:34 am

WARVOX WARDIALER HELP

Hello,
I'm not so much in experience with linux systems which means i'm unable to install "tar.gz"files successfully,I've tried goggling for help but i end up nowhere.
Kindly give me a detailed way forward i'm trying out Warvox-1.0.1 and my system is linuxmint 12,The other problem is i don't know much about Linux command prompts,I'd appreciate your help so much.
Thank you in advance
<<

rattis

User avatar

Hero Member
Hero Member

Posts: 1172

Joined: Mon Jul 27, 2009 1:25 pm

Post Tue Oct 09, 2012 11:31 am

Re: WARVOX WARDIALER HELP

What part of the install is giving you a problem?

tar -zxvf <filename>

change to directory then issue the proper commands to compile from source.


think that's right.

Since it's a tarball, you have to melt it first. It is currently in the TAR (archived) and Zipped (gz) format. the first command will un pack it (melt it).

simple stuff, the right google would guide you through what you need.
OSWP, Sec+
<<

cd1zz

User avatar

Recruiters
Recruiters

Posts: 566

Joined: Sun Oct 03, 2010 9:01 pm

Post Tue Oct 09, 2012 12:17 pm

Re: WARVOX WARDIALER HELP

Warvox is already in BackTrack, ready to be compiled.
<<

mosess

User avatar

Newbie
Newbie

Posts: 6

Joined: Tue Oct 09, 2012 8:04 am

Post Sat Nov 03, 2012 10:15 am

Re: WARVOX WARDIALER HELP

I'm think i'm almost done installing warvox on my linuxmint 12 system after i got this confirmation message..

" *
* WarVOX Installation Verifier *
* *
******************************
****************************************
[*] The KissFFT module appears to be available[*] The SOX binary appears to be available with RAW file support[*] The GNUPlot binary appears to be available[*] The LAME binary appears to be available[*] The IAXRECORD binary appears to be available
[*] Congratulations! You are now ready to run WarVOX[*] Start WarVOX with bin/warvox.rb

however i'm still not able to access warvox because the start command "bin/warvox"
gives the below results




"
yurigaitho@yurigaitho-HP-Compaq-dc7100-SFF-PC923A /usr/local/src/warvox-1.0.1 $ bin/warvox.rb
[*] Starting WarVOX on http://127.0.0.1:7777/

=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.2.2 application starting on http://127.0.0.1:7777
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load_without_new_constant_marking': no such file to load -- mongrel_rails (MissingSourceFile)
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/railties/lib/commands/servers/mongrel.rb:64
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:153:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:153:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/railties/lib/commands/server.rb:49
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from ./script/server:3
from bin/warvox.rb:72:in `load'
from bin/warvox.rb:72
yurigaitho@yurigaitho-HP-Compaq-dc7100-SFF-PC923A /usr/local/src/warvox-1.0.1 $


Official documentation for the final step are-
configure the WarVOX username, password, and data directory. To change these parameters, edit etc/warvox.conf. The default username is admin with a password of warvox. If you intend to dial large ranges and your system has more than one CPU or CPU core, change the analysis_threads value to twice the number of available processing units. Once WarVOX has been configured, execute the following command to start the web interface.

$ bin/warvox.rb

Once the web interface is started, it can be accessed from your browser at the URL http://127.0.0.1:7777/. Enter the username and password from the previous step to login.
google instruction are that i Change the username and password in /warvox-1.0.1/etc/warvox.conf and if all goes well i can launch it with

/bin/warvox.rb --address yourIPaddress --port 7777

but i really this is where i need help on the exact steps to take
thanks in advance
<<

venom77

User avatar

Hero Member
Hero Member

Posts: 1905

Joined: Mon Dec 11, 2006 3:23 pm

Post Sat Nov 03, 2012 4:17 pm

Re: WARVOX WARDIALER HELP

I'm not sure if this will help or not, but there were some extra things I had to install depending on version of WarVOX being used.

http://www.ethicalhacker.net/component/ ... ic,8125.0/
<<

mosess

User avatar

Newbie
Newbie

Posts: 6

Joined: Tue Oct 09, 2012 8:04 am

Post Tue Nov 06, 2012 1:32 am

Re: WARVOX WARDIALER HELP

Any one please help with step i should take to get warvox running on my mint 12 system i successfully got it installed but cannot proceed from the quoted final step

I'm using stable version warvox 1.0.1
what exactly should i do please understand i'm a noob with Unix systems

i got it with terminal commands

"cd /usr/local/src

tar -xvzf warvox-1.0.1.tar.gz
mv warvox-1.0.1 warvox2
cd warvox2

cp/usr/local/src/warvox/lib/kissfft.so ./lib/

apt-get install sqlite3-ruby

vi etc/warvox.conf

make

bin/warvox.rb --address 0.0.0.0 "


i'm getting results as-



#
# WarVOX Configuration
n/warvox.rb --address 0.0.0.0 #


#
# Configure the username and password for the WarVOX
# web interface. This password is sent in clear text
#
authentication:
  user: admin
  pass: warvox

#
# Configure the path to all saved data files
# This requires ~500M of space per 10k prefix
#
data_path: %BASE%/data/

#
# Configure filesystem paths to each required tool
#
tools:"

I have tried to type the default user and password "admin" and "warvox" but nothing happens..what i should i do next..

Thanks in advance
Last edited by mosess on Tue Nov 06, 2012 1:59 am, edited 1 time in total.
<<

venom77

User avatar

Hero Member
Hero Member

Posts: 1905

Joined: Mon Dec 11, 2006 3:23 pm

Post Tue Nov 06, 2012 7:41 am

Re: WARVOX WARDIALER HELP

Well, for one, you have to use Developmental code so keep that in mind. I played with it and was able to get it running but then the GUI was throwing errors once up and going. I spent as much time as I'm going to messing with it. Good luck.

Here's what I did on LinuxMint (v13):

  Code:
sudo apt-get update
sudo apt-get install git build-essential sox lame ruby ruby-dev rake rubygems ruby-bundler libopenssl-ruby libreadline-ruby libsqlite3-ruby gnuplot postgresql-8.4 postgresql-contrib-8.4 libpq-dev
sudo gem install mongrel

sudo su - postgres
createuser warvox
createdb warvox -O warvox
psql
alter user warvox with password 'password';
ctrl-D
psql template1
\i /usr/share/postgresql/8.4/contrib/_int.sql
ctrl-D
exit

git clone https://github.com/rapid7/warvox.git
cd warvox
vi web/config/database.yml (set port to 5432, update 'password')
vi etc/warvox.conf (change user/pass)

sudo make

vi web/config/initializers/session_store.rb (change line below as such)
  Web::Application.config.session_store :cookie_store, :key => '_web_session'

vi web/config/initializers/wrap_parameters.rb
  Comment out top ActiveSupport piece (lines 7-9)

sudo bin/warvox.rb
<<

mosess

User avatar

Newbie
Newbie

Posts: 6

Joined: Tue Oct 09, 2012 8:04 am

Post Tue Nov 06, 2012 9:08 am

Re: WARVOX WARDIALER HELP

I meant i cannot access the web interface note as the instructions say i should start warvox web interface with "bin/warvox.rb" Once the web interface is started, it can be accessed from your browser at the URL http://127.0.0.1:7777/. Enter the username and password from the previous step to login. but when i type "bin/warvox.rb" in the same terminal i get this


yurigaitho@yurigaitho-HP-Compaq-dc7100-SFF-PC923A /usr/local/src/warvox-1.0.1 $ bin/warvox.rb
[*] Starting WarVOX on http://127.0.0.1:7777/

=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.2.2 application starting on http://127.0.0.1:7777
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load_without_new_constant_marking': no such file to load -- mongrel_rails (MissingSourceFile)
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/railties/lib/commands/servers/mongrel.rb:64
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:153:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:153:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/railties/lib/commands/server.rb:49
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from ./script/server:3
from bin/warvox.rb:72:in `load'
from bin/warvox.rb:72


With your instructions i'm getting error-



sudo apt-get install git build-essential sox lame ruby ruby-dev rake rubygems ruby-bundler libopenssl-ruby libreadline-ruby libsqlite3-ruby gnuplot postgresql-8.4 postgresql-contrib-8.4 libpq-dev
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

when i run the command 'sudo dpkg --configure -a'terminal changes outlook and cannot be accessed    ...it contains the message


"Package configuration                                                         
                                                                               
┌─────────────────────┤ Configuring postgresql-common ├─────────────────────┐ 
│                                                                          │ 
│ Obsolete major version 8.4                                                 
│                                                                             
│ The PostgreSQL version 8.4 is obsolete, but the server or client           
│ packages are still installed. Please install the latest packages           
│ (postgresql-9.1 and postgresql-client-9.1) and upgrade the existing         
│ clusters with pg_upgradecluster (see manpage).                             
│                                                                             
│ Please be aware that the installation of postgresql-9.1 will               
│ automatically create a default cluster 9.1/main. If you want to upgrade     
│ the 8.4/main cluster, you need to remove the already existing 9.1           
│ cluster (pg_dropcluster --stop 9.1 main, see manpage for details).         
│                                                                             
│ The old server and client packages are no longer supported. After the       
│ existing clusters are upgraded, the postgresql-8.4 and                     
│                                                                             
│                                  <Ok>                                       
│                                                                          │ 
└───────────────────────────────────────────────────────────────────────────┘"

i'm surprised how installing warvox can be mind boggling..i'm hoping someone to help me out
Thanks in advance
Last edited by mosess on Tue Nov 06, 2012 9:34 am, edited 1 time in total.
<<

venom77

User avatar

Hero Member
Hero Member

Posts: 1905

Joined: Mon Dec 11, 2006 3:23 pm

Post Tue Nov 06, 2012 4:40 pm

Re: WARVOX WARDIALER HELP

It's a pain. Took me a while to get it working properly when I needed it too. And as I posted in the other thread, I had an easier time with the stable version rather than the developmental version. Even with the instructions I posted here, once I got the GUI running with those commands, it had other issues. May be due to the version of Linux, may just be that it needs some more coding/work.

I would recommend using BackTrack instead if you need to get up and running quickly.
<<

mosess

User avatar

Newbie
Newbie

Posts: 6

Joined: Tue Oct 09, 2012 8:04 am

Post Fri Nov 23, 2012 10:46 am

Re: WARVOX WARDIALER HELP

Thank all for your help i finally got it running on Ubuntu 10.04  had a few issue with ruby gems but solved

cd /usr/local/src

tar zxvf warvox-1.0.1.tar.gz


sudo apt-get install build-essential libiaxclient-dev sox lame ruby ruby-dev rake rubygems libopenssl-ruby libreadline-ruby libsqlite3-ruby gnuplot

sudo gem install mongrel

cd warvox-1.0.1/ && make


What providers do you suggest...
<<

venom77

User avatar

Hero Member
Hero Member

Posts: 1905

Joined: Mon Dec 11, 2006 3:23 pm

Post Wed Nov 28, 2012 4:11 pm

Re: WARVOX WARDIALER HELP

Check Vitelity. You will need to call them and let them know what you are doing though so that they can properly setup your account. This will allow you to directly connect to them using WarVox.

Another option (that I've used previously) is VoicePulse but I had to setup a local Asterisk server with IAX2 support first, and then send WarVox to that and then to the provider. For that reason, Vitelity would be an easier option.
<<

mosess

User avatar

Newbie
Newbie

Posts: 6

Joined: Tue Oct 09, 2012 8:04 am

Post Fri Dec 21, 2012 10:11 am

Re: WARVOX WARDIALER HELP

Thanks Biiv and all for support..i'm now running warvox with Vitelity without any hussles..Thanks once again
<<

venom77

User avatar

Hero Member
Hero Member

Posts: 1905

Joined: Mon Dec 11, 2006 3:23 pm

Post Fri Jan 04, 2013 9:27 am

Re: WARVOX WARDIALER HELP

Wow, that's interesting to know. I actually had a co-worker contact me recently about setting up a war-dialing assessment. I called Vitelity directly and talked with their sales, they told me they were no longer supporting IAX2 directly. I thought maybe the guy didn't know what I was talking about. Thanks for posting a follow-up.

In any case, we found a different provider to work directly with warvox that worked very well. That company is Rapidvox.

Return to Network Pen Testing

Who is online

Users browsing this forum: No registered users and 3 guests

cron
.
Powered by phpBB® Forum Software © phpBB Group.
Designed by ST Software