.

Social Engineering Toolkit - problem with Spear-Phishing attack !

<<

piersf

Newbie
Newbie

Posts: 7

Joined: Fri Nov 04, 2011 4:40 pm

Post Tue Jul 24, 2012 12:22 pm

Social Engineering Toolkit - problem with Spear-Phishing attack !

Hello guys!


I am having a problem with SET when i try to do the Spear-Fishing attack. I thought to make a video about it, so you can see better what steps i make , instead of trying to describe you the problem, which would be confusing.

Please look at this video https://www.youtube.com/watch?v=6ZR0RVyEET0  and if anyone know, let me know what the hell is wrong.

I am searching for two days now, for this problem, and haven't found anything, or anyone who had the same or similar problem.

Thank you in advance !
<<

piersf

Newbie
Newbie

Posts: 7

Joined: Fri Nov 04, 2011 4:40 pm

Post Tue Jul 24, 2012 5:23 pm

Re: Social Engineering Toolkit - problem with Spear-Phishing attack !

Nobody knows how to fix this,  or any other idea of what might be the problem ?
<<

cd1zz

User avatar

Recruiters
Recruiters

Posts: 566

Joined: Sun Oct 03, 2010 9:01 pm

Post Wed Jul 25, 2012 3:29 pm

Re: Social Engineering Toolkit - problem with Spear-Phishing attack !

Blow away the SET directory and pull down a fresh copy. You're correct that the file should be created at that point so something must be wrong with your setup.

svn co http://svn.trustedsec.com/social_engineering_toolkit set/
<<

piersf

Newbie
Newbie

Posts: 7

Joined: Fri Nov 04, 2011 4:40 pm

Post Wed Jul 25, 2012 4:37 pm

Re: Social Engineering Toolkit - problem with Spear-Phishing attack !

Thank you for replying !

Still nothing mate. I completely removed the old set and downloaded again as you said, but still the same problem.

I even updated & upgraded Backtrack, but again nothing. The problem still remains.

Do you think that maybe this is a Backtrack problem and i should uninstall it, and install it again ?

Cause i'm out of ideas at this point.

Thank you again !
<<

cd1zz

User avatar

Recruiters
Recruiters

Posts: 566

Joined: Sun Oct 03, 2010 9:01 pm

Post Wed Jul 25, 2012 4:40 pm

Re: Social Engineering Toolkit - problem with Spear-Phishing attack !

Do the other set modules work? It might be a metasploit issue. Is your set_config pointed to the right metasploit dir?
<<

piersf

Newbie
Newbie

Posts: 7

Joined: Fri Nov 04, 2011 4:40 pm

Post Wed Jul 25, 2012 5:20 pm

Re: Social Engineering Toolkit - problem with Spear-Phishing attack !

I worked before with Metasploit doing other attacks and everything was fine. No problems at all. Metasploit on my machine is located at /opt/metasploit/msf3 ,that is, the one that Backtrack had when i installed it.

My set_config file is pointed to the right Metasploit directory (to the one above).

Regarding the other modules, when i try to do the Java Applet Attack Method -Site Clone, and get to the point where it should encode the payload, i select shigata_ga_nai encoding in order to bypass the AV, then it throws some errors :

  Code:
/usr/lib/ruby/1.8/rubygems.rb:1051: undefined method `gem' for module `Kernel' (NameError)
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `fastlib_original_require'
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit/msf3/lib/packetfu/packetfu.rb:12
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `fastlib_original_require'
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit/msf3/lib/packetfu.rb:4
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `fastlib_original_require'
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit/msf3/lib/msf/core/db.rb:28
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `fastlib_original_require'
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit/msf3/lib/msf/core/db_manager.rb:5
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `fastlib_original_require'
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit/msf3/lib/msf/core/framework.rb:69
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `fastlib_original_require'
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit/msf3/lib/msf/core.rb:34
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `fastlib_original_require'
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit/msf3/lib/msf/ui/console/driver.rb:2
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `fastlib_original_require'
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit/msf3/lib/msf/ui/console.rb:11
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `fastlib_original_require'
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit/msf3/lib/msf/ui.rb:11
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `fastlib_original_require'
from /opt/metasploit/msf3/lib/fastlib.rb:369:in `require'
from /opt/metasploit/msf3/msfvenom:257


I haven't tried all the modules of set.

Return to Network Pen Testing

Who is online

Users browsing this forum: No registered users and 2 guests

cron
.
Powered by phpBB® Forum Software © phpBB Group.
Designed by ST Software