Running Nmap from MSFconsole Error




Posts: 36

Joined: Thu Jun 14, 2012 9:48 am

Post Wed Jun 20, 2012 11:24 am

Running Nmap from MSFconsole Error

              When i run nmap from Metasploit console, i get error when i check  the results from the scan are stored in the database, when i run db_services,  i get  Unknown command: db_services, what could be this problem, if you have suggestions please let me know.

Thank you

msf > db_connect postgres:toor@
msf > db_status

    postgresql connected to msf3

msf > db_nmap -sS -A

scan completes
msf > db_services
[-] Unknown command: db_services.

Backtrack 5R2/Windows xp sp2 > Virtual Box


User avatar

Sr. Member
Sr. Member

Posts: 379

Joined: Tue Dec 30, 2008 1:53 pm

Post Wed Jun 20, 2012 1:39 pm

Re: Running Nmap from MSFconsole Error

Try the "services" command instead.

They did away with db_services with Metasploit 4.0, I believe.

eCPPT - GSEC - GCIH - GWAPT - GCUX - RHCE - SCSecA - Security+ - Network+

Return to Network Pen Testing

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB® Forum Software © phpBB Group.
Designed by ST Software