.

Metasploit Framework on Mac OSX Help!!!

<<

canislupis100

Newbie
Newbie

Posts: 7

Joined: Sat Mar 05, 2011 8:41 pm

Post Sat Mar 05, 2011 8:44 pm

Metasploit Framework on Mac OSX Help!!!

I am a College Senior and am working on a midterm, and for that I am supposed to use metasploit framework. The problem is, whenever I try to run the msfconsole, I receive the following error:


localhost:~ Amy$ /Users/Amy/Desktop/Metasploit/msfconsole ; exit;
<internal:lib/rubygems/custom_require>:29:in `require': no such file to load -- msf/base/sessions/command_shell_options (LoadError)
from <internal:lib/rubygems/custom_require>:29:in `require'
from /Users/Amy/Desktop/Metasploit/lib/msf/core/auxiliary/commandshell.rb:5:in `<top (required)>'
from <internal:lib/rubygems/custom_require>:29:in `require'
from <internal:lib/rubygems/custom_require>:29:in `require'
from /Users/Amy/Desktop/Metasploit/lib/msf/core/auxiliary/mixins.rb:17:in `<top (required)>'
from <internal:lib/rubygems/custom_require>:29:in `require'
from <internal:lib/rubygems/custom_require>:29:in `require'
from /Users/Amy/Desktop/Metasploit/lib/msf/core/auxiliary.rb:15:in `<class:Auxiliary>'
from /Users/Amy/Desktop/Metasploit/lib/msf/core/auxiliary.rb:13:in `<module:Msf>'
from /Users/Amy/Desktop/Metasploit/lib/msf/core/auxiliary.rb:3:in `<top (required)>'
from <internal:lib/rubygems/custom_require>:29:in `require'
from <internal:lib/rubygems/custom_require>:29:in `require'
from /Users/Amy/Desktop/Metasploit/lib/msf/core.rb:51:in `<top (required)>'
from <internal:lib/rubygems/custom_require>:29:in `require'
from <internal:lib/rubygems/custom_require>:29:in `require'
from /Users/Amy/Desktop/Metasploit/lib/msf/ui/console/driver.rb:1:in `<top (required)>'
from <internal:lib/rubygems/custom_require>:29:in `require'
from <internal:lib/rubygems/custom_require>:29:in `require'
from /Users/Amy/Desktop/Metasploit/lib/msf/ui/console.rb:10:in `<top (required)>'
from <internal:lib/rubygems/custom_require>:29:in `require'
from <internal:lib/rubygems/custom_require>:29:in `require'
from /Users/Amy/Desktop/Metasploit/lib/msf/ui.rb:10:in `<top (required)>'
from <internal:lib/rubygems/custom_require>:29:in `require'
from <internal:lib/rubygems/custom_require>:29:in `require'
from /Users/Amy/Desktop/Metasploit/msfconsole:113:in `<main>'
logout


Can anyone help me figure out how to fix this? I have searched online, and have found no other posts concerning this, except for those I have posted[color=blue]
.

Any assistance would be greatly appreciated!

Thank You![/color]
<<

H4TT1fn4TT

User avatar

Jr. Member
Jr. Member

Posts: 54

Joined: Tue Feb 08, 2011 2:48 pm

Location: Void

Post Sun Mar 06, 2011 10:28 am

Re: Metasploit Framework on Mac OSX Help!!!

Just a wild guess but do you have RubyGems installed?

http://rubygems.org/
Last edited by H4TT1fn4TT on Sun Mar 06, 2011 10:31 am, edited 1 time in total.
"The quality of programmers is a decreasing function of the density of go to statements in the programs they produce."
<<

canislupis100

Newbie
Newbie

Posts: 7

Joined: Sat Mar 05, 2011 8:41 pm

Post Sun Mar 06, 2011 2:06 pm

Re: Metasploit Framework on Mac OSX Help!!!

I will try that. I installed these programs yesterday in the following order:

Apple Xcode
Macports
Ruby 1.9.1
sqlite3
sqlite3-ruby
metasploit framework

Thank you!




--I just tried installing / updating rubygems, and it fixed 3 bugs, but I still have the same error when I try to launch msfconsole.
Last edited by canislupis100 on Sun Mar 06, 2011 2:24 pm, edited 1 time in total.
<<

AndyB67

User avatar

Full Member
Full Member

Posts: 100

Joined: Fri Jan 14, 2011 7:13 am

Location: UK

Post Sun Mar 06, 2011 5:16 pm

Re: Metasploit Framework on Mac OSX Help!!!

It's not liking/missing one of the gems it needs for the command shell. 

Have you tried running the 'gem update --system' followed by 'gem install bundler' from within the metasploit framework folder?

You may also need to run svn update in the same location.

It looks like you checked out the instructions on the Metasploit site, it may be worth going on their IRC and/or forums with the error
Net+ Sec+ More to come
<<

canislupis100

Newbie
Newbie

Posts: 7

Joined: Sat Mar 05, 2011 8:41 pm

Post Sun Mar 06, 2011 10:19 pm

Re: Metasploit Framework on Mac OSX Help!!!

Ok, I shall try that. Thank you very much! I did try updating and reinstalling, but to no avail.
<<

AndyB67

User avatar

Full Member
Full Member

Posts: 100

Joined: Fri Jan 14, 2011 7:13 am

Location: UK

Post Mon Mar 07, 2011 4:44 pm

Re: Metasploit Framework on Mac OSX Help!!!

Have suffered with ruby-gems  and it's dependencies myself a few times, can be frustrating sometimes
Net+ Sec+ More to come

Return to Tools

Who is online

Users browsing this forum: No registered users and 1 guest

.
Powered by phpBB® Forum Software © phpBB Group.
Designed by ST Software