.

metasploit 3.1 problems

<<

ethanhunt

Newbie
Newbie

Posts: 7

Joined: Fri Apr 04, 2008 10:53 pm

Post Mon Apr 14, 2008 12:43 am

metasploit 3.1 problems

i downloaded metasploit 3.1 and the install was flawless.
i downloaded ruby as well same results.
now when i try and open "metasploit gui or metasploit web" it just show quick dos box and disappears. The gui doesnt even open at all. Any ideas what could possibly be wrong?

further more info: im currently running "vista home pre"
<<

Mr. Roboto

User avatar

Jr. Member
Jr. Member

Posts: 67

Joined: Thu Feb 14, 2008 9:57 am

Location: Ohio

Post Mon Apr 14, 2008 5:05 pm

Re: metasploit 3.1 problems

I have MS 3.1 and Ruby loaded on Vista Home Premium. Metasploit works perfectly.

If I am reading your post correctly, Metasploit became non-functional after the Ruby install?
A+, Security+, HDI Support Center Analyst, MCTS: Vista
<<

ethanhunt

Newbie
Newbie

Posts: 7

Joined: Fri Apr 04, 2008 10:53 pm

Post Mon Apr 14, 2008 10:39 pm

Re: metasploit 3.1 problems

No actually im getting the same output even before i downloaded ruby.
i downloaded metasploit the first time without ruby installed and got the same results. everytime i tried to open metasploit web it was just a quick dos box and dissappears and metasploit gui dont even open.

So i tried downloading ruby, and the samething happens.
it shows a quick dos box and disappears.

Have you downloaded netcat and just clicked on the program and it just showed a quick dos box then closed unless you put it in a particular directory?

Thats exactly what metasploit 3.1 is doing to me. just showing the dos box whenever i click on the metasploit web.
<<

Kev

Sr. Member
Sr. Member

Posts: 428

Joined: Sat Sep 29, 2007 12:26 pm

Post Tue Apr 15, 2008 12:03 am

Re: metasploit 3.1 problems

My guess is you are still short a few ruby packages.

# apt-get install ruby libruby rdoc
# apt-get install libyaml-ruby
# apt-get install libzlib-ruby
# apt-get install libopenssl-ruby
# apt-get install libdl-ruby
# apt-get install libreadline-ruby
# apt-get install libiconv-ruby
# apt-get install rubygems
And dont forget:
# gem install -v=1.2.2 rails
If you would like to use the experimental GUI, you will need to install the following packages:
# apt-get install libgtk2-ruby libglade2-ruby
<<

ethanhunt

Newbie
Newbie

Posts: 7

Joined: Fri Apr 04, 2008 10:53 pm

Post Tue Apr 15, 2008 2:08 am

Re: metasploit 3.1 problems

ok so ive just downloaded metasploit version (3) and works perfectly.
i cant get 3.1 to work properly so i just backtracked a bit. I'm just going to use version (3) instead of (3.1).

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 0 guests

.
Powered by phpBB® Forum Software © phpBB Group.
Designed by ST Software