Post Tue Oct 25, 2016 9:20 am

Need help escalating privileges on linux kernel 2.4.20-8

Hi Guys,

I'm learning penetration testing and need some help with escalating my privileges on a Red Hat 9 (Shrike - kernel 2.4.20-8 - http://archive.download.redhat.com/pub/ ... /iso/i386/) test VM. I'm stuck.... I'm using this exploit (https://www.exploit-db.com/exploits/160/) and keep getting "Segmentation fault" errors. I've tried others as well that should work but all appear to give me the same error. I could not find any helpful information on how to resolve this. I've tried debugging the code but I'm not a programmer so it's been a pain, also tired changing RAM size and running the VM on different host machines as some suggested online but no luck. Anyone has any ideas or suggestions? I can provide more information if need be. Any help would be greatly appreciated.

Here a screenshot: https://imgur.com/a/7mFHI

Thanks.