VMWare Workstation 7 + BT5 R3 No networking

This topic contains 6 replies, has 4 voices, and was last updated by  m0wgli 6 years, 9 months ago.

  • Author
    Posts
  • #7997
     skorpinok 
    Participant

    Hello,
                I Have BT5 R3 running on VMWare workstation 7. Recently copied the cloned BT5-R3 on my new  Dell xps notebook, The network adapter is set to Bridged mode,The ‘Replicate Physical network state’ is checked. when i type ifconfig on my backtrack terminal it shows inet addr:127.0.0.1  Mask:255.0.0.0, can anyone please suggest me how to fix this ?

    Regards
    Skorpinok.

  • #50745
     sh4d0wmanPP 
    Participant

    I’ll usually run with NAT so you could check that.

    However regarding your problem: is your network up while testing? As you have “replicate network state” it is easy to unplug your laptop and forgot that this breaks your VM networking as well.

    Other things to check:
    – what adapters you see with ifconfig?

  • #50746
     skorpinok 
    Participant

    @sh4d0wmanpp wrote:

    I’ll usually run with NAT so you could check that.

    However regarding your problem: is your network up while testing? As you have “replicate network state” it is easy to unplug your laptop and forgot that this breaks your VM networking as well.

    Other things to check:
    – what adapters you see with ifconfig?

    Even with NAT its same,

    root@bt:~# ifconfig
    lo        Link encap:Local Loopback 
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:223 errors:0 dropped:0 overruns:0 frame:0
              TX packets:223 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:26146 (26.1 KB)  TX bytes:26146 (26.1 KB)

  • #50747
     m0wgli 
    Participant
  • #50748
     dynamik 
    Participant

    Do you see your NIC if you do an ifconfig -a?

    Maybe you just need a ifconfig eth0 up or service networking start.

    You can also do a dmesg | grep eth to see interfaces detected during startup.

  • #50749
     skorpinok 
    Participant

    Thank you  ajohnson & sh4d0wmanPP , Problem resolved, after hours of checking, the main culprit was this new  macafee antivirus, that came pre installed with my new dell xps, its home network settings would not allow network adapters to vm’s. so i uninstalled it & reinstalled with norton antivirus 2012. fired up backtrack. an ifconfig shows.
    eth2   Link encap:Ethernet  HWaddr 00:0c:29:95:57:84
     inet addr:192.168.1.41  Bcast:192.168.1.255  Mask:255.255.255.0
     inet6 addr: fe80::20c:29ff:fe95:5784/64 Scope:Link
     UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
     RX packets:475 errors:0 dropped:0 overruns:0 frame:0
     TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
     collisions:0 txqueuelen:1000
     RX bytes:31955 (31.9 KB)  TX bytes:2929 (2.9 KB)
     Interrupt:19 Base address:0x2000

    lo     Link encap:Local Loopback
     inet addr:127.0.0.1  Mask:255.0.0.0
     inet6 addr: ::1/128 Scope:Host
     UP LOOPBACK RUNNING  MTU:16436  Metric:1
     RX packets:179 errors:0 dropped:0 overruns:0 frame:0
     TX packets:179 errors:0 dropped:0 overruns:0 carrier:0
     collisions:0 txqueuelen:0
     RX bytes:26266 (26.2 KB)  TX bytes:26266 (26.2 KB)
    root@bt:~# ping http://www.google.com
    PING http://www.google.com (173.194.45.19) 56(84) bytes of data.
    64 bytes from http://www.google.com (173.194.45.19): icmp_seq=1 ttl=50 time=166 ms
    64 bytes from lis01s06-in-f19.1e100.net (173.194.45.19): icmp_seq=2 ttl=50 time=166 ms
    64 bytes from lis01s06-in-f19.1e100.net (173.194.45.19): icmp_seq=3 ttl=50 time=

  • #50750
     m0wgli 
    Participant

    Glad you got the problem sorted. I note you now have eth2, if this is a problem for you, refer to my previous post which explains how you can get eth0 back.

You must be logged in to reply to this topic.

Copyright ©2019 Caendra, Inc.

Contact Us

Thoughts, suggestions, issues? Send us an email, and we'll get back to you.

Sending

Sign in with Caendra

Forgot password?Sign up

Forgot your details?