VMWare Client Question

Viewing 24 reply threads
  • Author
    Posts
    • #4793
      Dengar13
      Participant

      Can someone please tell me how I can get Internet access on a VMWare Client?  I am using a Windows XP base OS and went to VM/Settings/Network Adapter/and switched it to NAT, but still can’t get access.

      Thanks in advance!

    • #30046
      UNIX
      Participant

      Mh, NAT should work. Did you try Bridged? Can you connect from your Guest OS to your Host OS or vice versa?
      Which product from VMware are you using?

    • #30047
      hayabusa
      Participant

      How is the VM setup, and is the VMWare NAT adapter enabled and allowed through the Windows firewall on the host?

    • #30048
      Dengar13
      Participant

      I just looked and the WF is off.  I am using VMWare Player 3.0.1.  I tried bridge and bridge + replicate physical network state and nothing yet.  I cannot ping my WMClient from my host OS and vice versa.  My IP on my host is 192.168.220.1 and my IP on my client is 192.168.1.8.  Could this be the issue?

    • #30049
      hayabusa
      Participant

      @Dengar13 wrote:

      I just looked and the WF is off.  I am using VMWare Player 3.0.1.  I tried bridge and bridge + replicate physical network state and nothing yet.  I cannot ping my WMClient from my host OS and vice versa.  My IP on my host is 192.168.220.1 and my IP on my client is 192.168.1.8.  Could this be the issue?

      It’s the issue if your subnet mask is 255.255.255.0…..

      Your machines are NOT on the same subnet.

      A NAT’d machine should be able to hit the internet, but you won’t be able to ping between the two addresses listed.  If you want to ping between host and guest, you need to find out the assigned IP address to the NAT adapter in the host, and make certain that IP, and the IP of the guest, are on the same subnet.

    • #30050
      Dengar13
      Participant

      Thanks guys.  I am VERY new to VMWare and thought once I saw it that the subnets being different could be the reason, but thought I’d ask first. 

    • #30051
      UNIX
      Participant

      So is it working now? Different subnet was the part I thought of too, when I saw your posted IPs. 😉

    • #30052
      hayabusa
      Participant

      Well, again, that MIGHT not be the reason for the Internet access failure.  IF the NAT adapter on the host IS on the same subnet as the guest (if IT is configured for NAT, also) then the guest SHOULD be able to ping the outside world and / or browse the internet.  But if the host NAT adapter is the one you gave the IP address for, then you definitely aren’t going anywhere.

      Whatever mode your guest is on (Bridged or NAT,) you need to make sure it’s IP is on the subnet with the IP of the host’s adapter for the network, in question.  (Also, if you’re bridged in the guest, you need to make sure WHICH adapter on the host the bridge is assigned to, and make sure that the IP of the guest is on the network that your host is on.)

    • #30053
      KamiCrazy
      Participant

      I’m not sure I am reading your explanation correctly hayabusa but I don’t think that is how NAT works in vmware…

      If you are using bridged networking then you either need to assign a static IP on the network your adapter is connected to or more logically receive a DHCP lease.

      If you are using NAT networking what happens is that vmware creates an internal network inside your host and automatically assigns the guest with a DHCP lease for the internal network.
      This internal network is then NAT’ed on your network adapter which is on your local subnet. This part obviously does not work if the guest’s NAT network adapter is assigned a static IP which is different to the internal network.

    • #30054
      hayabusa
      Participant

      You’re correct, you didn’t understand my post.  (Sorry, maybe I worded it poorly this time.)

      What I intended was this:

      If you’re using NAT for the guest, you’re correct, in that the guest (IF configured for DHCP) will get an address from the NAT, and be able to use that address to reach the outside world.  (Per my statement – IF the NAT adapter on the host IS on the same subnet as the guest (if IT is configured for NAT, also) then the guest SHOULD be able to ping the outside world and / or browse the internet.)

      I then should’ve clarified, when I talked about the NAT adapter.  I meant to say the NAT network configured for the NAT adapter on the host should have a subnet matching the IP that the guest shows.  If the guest showed an IP of 192.168.1.8 (as he noted) and the host NAT configured network was 192.168.220.1 (which was what I wanted to clarify) then he obviously didn’t have the client getting address from DHCP on the NAT, and the address would NOT ping out.  (Which you noted when you said – This part obviously does not work if the guest’s NAT network adapter is assigned a static IP which is different to the internal network.)

      Sorry if I left it vague.  I had meant to say the NAT network in the config in VMWare, not the adapter, itself.  Was very preoccupied today, with work, and somehow, missed that I said it that way.  Sorry for any confusion.

    • #30055
      j0rDy
      Participant

      remember that if your DHCP fails to give you a proper dynamic IP address you can use, set it to a static IP address. i encountered this a lot with use of the De-Ice disks i downloaded for my pentest lab.

    • #30056
      Dutchie
      Participant

      I suppose you are working wireless!!

      Well VMware does not work on the build-in radio adaptar!!  You have to use a USB-adaptar or plug your device on a CAT5

    • #30057
      hayabusa
      Participant

      Odd…  I bridge to my wireless NIC all the time.  VMWare still uses it’s built in VMWare tools adapter, in the guest, but I have no issue bridging or NAT’ing to my physical wireless adapters, built-in or otherwise.

    • #30058
      Dutchie
      Participant

      Well I only have experience with VM in combination with Backtrack. The PCI card within Backtrack virtual does not work. After investigating the forum of Backtrack, I found a confirmation that Backtrack only works with USB-adaptars.

      So It seems VM OS or VM distro dependent if the PCI-card is working!!

    • #30059
      hayabusa
      Participant

      Well, what VMWare WON’T do with the built-in adapter (with a BT guest) is packet injection for wireless, even on a supported card.  This is because of how (I believe) VMWare sets up it’s adapter to use the host’s network adapter (assigning it to a more generic network driver.)  I still need to use USB or other for packet injection with BT4, if I have it in a VM guest.  But for general networking purposes, I’ve had no issues bridging or NAT’ing against a built-in wireless adapter from my guest to my host.

    • #30060
      Anonymous
      Participant

      @Dengar13 wrote:

      Can someone please tell me how I can get Internet access on a VMWare Client?  I am using a Windows XP base OS and went to VM/Settings/Network Adapter/and switched it to NAT, but still can’t get access.

      Thanks in advance!

      Don’t take this wrong, as it is not meant to be snide. The manual has an excellent tutorial on the types of networking available.

    • #30061
      Dengar13
      Participant

      Don’t take this wrong, as it is not meant to be snide. The manual has an excellent tutorial on the types of networking available.

      I didn’t take it as a snide comment at all and thank you for pointing me in that direction.  I got it to work during our CTF event.  It was a combination of two things for me:  setting the client up for DHCP as it was statically assigned and setting it to bridge mode.  Once I got those two things set I was good to go.

      Thanks for the help/suggestions/pointers.

    • #30062
      UNIX
      Participant

      Little OT, but may I ask which CTF event it was? 🙂

    • #30063
      hayabusa
      Participant

      Glad you got it working, and glad we could help.  Hope your CTF was good.

    • #30064
      Dengar13
      Participant

      @awesec wrote:

      Little OT, but may I ask which CTF event it was? 🙂

      It was pretty cool as it was my first.  I was in a team of three and got 2/3 flags.  I learned a very important thing:  Wikto is my friend!    😉  It was a CTF event for the Sec 542 class.  They had a treasure hunt the night before that I participated in and did better than I had anticipated.  I won’t say what I scored as I am a bit embarrassed, but did well in my mind and got experience/learned from it so that was great for me.  Besides, they had free beer so that was a sweet bonus.  ;D

    • #30065
      hayabusa
      Participant

      Free beer…  ALWAYS a nice bonus!  Congrats on the event, and glad you enjoyed it, and learned lots from your class.

    • #30066
      UNIX
      Participant

      I try to participate in as many CTFs as possible and have learned in each of them at least a few new things. Scores and rankings are nice and everything, also if you know many of the other teams, but the fun and learning aspect is always great.

    • #30067
      unsupported
      Participant

      Sounds like SANS2010.

    • #30068
      Dengar13
      Participant

      @unsupported wrote:

      Sounds like SANS2010.

      Yup, it was.  The one that just concluded in Orlando.

    • #30069
      unsupported
      Participant

      Sweet.  I faciliated 505: Securing Windows.  I wanted to stick around to do the Treasure Hunt, well, heck, to do any of the evening events, but I’m local and did not want to miss out on spending time with my daughter.

Viewing 24 reply threads
  • You must be logged in to reply to this topic.

Copyright ©2020 Caendra, Inc.

Contact Us

Thoughts, suggestions, issues? Send us an email, and we'll get back to you.

Sending

Sign in with Caendra

Forgot password?Sign up

Forgot your details?