transparent wireless bridging – help needed

Viewing 1 reply thread
  • Author
    Posts
    • #2768
      rma88
      Participant

      Hey everyone, I’m trying to setup a transparent wireless bridge, but traffic is only making it to 2 of the 3 interfaces.. I could really use some help here.

      Heres the situation, I am trying to “extend” the range of my ap. I have a laptop with two wireless cards ( 1 atheros, 1 intel 3945abg ). I am putting one interface into ap mode, the other into managed, bridging the connection, but traffic is only seen on nic hosting the ap, and the bridge. the interface in managed mode isn’t receiving any of the traffic. here is how i’m doing it:

      ifconfig ath0 down
      wlanconfig ath0 destroy
      wlanconfig ath0 create wlandev wifi0 wlanmode master (master or ap?same?)
      ifconfig wlan0 0.0.0.0 up
      iwconfig wlan0 essid “office” key xxxxxxxxxx
      ifconfig ath0 0.0.0.0 up
      iwconfig ath0 essid “extension”

      brctl addbr br0
      brctl addif br0 wlan0
      brctl addif br0 ath0
      ifconfig br0 up
      dhclient br0 (or ifconfig br0 192.168.1.100 netmask 255.255.255.0 broadcast 192.168.1.255)

      Now if a client connects to “extension” and requests an ip address via dhcp, i can see traffic (via wireshark) on ath0(the ap nic) and br0; however, wlan0(the nic in managed mode connected to “office”) doesn’t see anything.

      some of my key questions are :
      1. does wlan0 need to be associated w/ the “office” ap? that only happens when i give it an ip address…so would i need to assign it one to get associated then set my ip 0.0.0.0 on wlan0 again?
      2. do i need to set a default route for anything, br0 maybe?
      # route add default gw 192.168.1.1 br0
      3. my ap currently uses stp ( i can see from the wireshark output ), so i’m assuming i need : brctl br0 stp on ??

      Thanks so much for any help, it is greatly appreciated as this has been going unsuccessfully for me for a while.
      Thanks

    • #19435
      rma88
      Participant

      Hey everyone, heres an update:

      I’m at the 97% mark and just wanted to ask a quick question:

      I have wireless transparent bridging setup, and my laptop acts as an extension of the ap. my other computer can see my laptops network, join it, and traffic makes it all the way across the bridge in my laptop over to the connected computer. The only problem is it seems that no other hosts can communicate with the default gateway ( the actual ap ). broadcasts are seen (via wireshark), and i can see network traffic. But when a connected host requests and address via dhcp, no reply from the default gw. when i statically assign an ip and try to ping the default gw, there is only an arp request for 192.168.1.1, no responce. So it seems like nothing can communicate with the default gw other than my laptop.

      i found out at linuxfoundation.org  that :
      “This is a known problem, and it is not caused by the bridge code. Many wireless cards don’t allow spoofing of the source address. It is a firmware restriction with some chipsets.”
      So it seems maybe my card cannot spoof its MAC.

      i can use dhclient and get an ip address for br0 when it is using the same MAC as wlan0 ( the interface connected to the “office” ap ), but when i use macchanger and set it to my ath0 (interface used as an “extension”) dhclient fails to receive an ip.

      So i’m thinking that only the mac associated w/ the “office” ap can communicate w/ the default gw, apparently being associated with me and then being bridged accross does not work (unless i have a prism chipset according to linuxfoundation.org)

      So…should I use NAT to take all the traffic from ath0(ap mode) and make it look like its coming from me. again using the bridge and everything. so basically all this requires is wireless transparent bridging and NAT?

      does that make sence, is that the best way to go about it? also, any point in the right direction to a specific NAT program or site would be great as i’ve never set up NAT on my box before.

      thanks everyone i really appreciate the help, sorry for the length, thanks!

Viewing 1 reply thread
  • You must be logged in to reply to this topic.

Copyright ©2021 Caendra, Inc.

Contact Us

Thoughts, suggestions, issues? Send us an email, and we'll get back to you.

Sending

Sign in with Caendra

Forgot password?Sign up

Forgot your details?