Question with SNMP Enumeration

Viewing 5 reply threads
  • Author
    Posts
    • #6929
      blueaxis
      Participant

      I am trying to understand why running both these tools is giving me different results or information. I am referring to “snmpwalk” and “snmpenum”.

      I ran both these against a linux host. Primarily snmpenum outputs the running tcp/udp services while snmpwalk is showing nothing.

      Just wanted to understand if this is (or not) related to command switches.

      Here is my input:

      snmpwalk -c public -v1 ip-address 1

      Thanks in advance

    • #43024
      lorddicranius
      Participant

      I’m interested in learning how these work as well, so I’ve been doing a little searching to see if I can lend a hand.  SNMP is something I need to learn more about…

      The “1” after the IP address, what’s that for?  And have you tried specifying different SNMP versions with the “-v” option, or do you know it’s v1 running on your target machine?

    • #43025
      Darktaurus
      Participant

      I would agree with lorddicranius.  Ensure that the snmp version is 1 and not 2c or 3. You could use nmap (NSE) scripts to help.  They have snmp scripts that might help you out.  I think they even use some form of snmpwalk in the scripts anyway.  Hopefully that helps.

      http://nmap.org/nsedoc/scripts/snmp-brute.html

    • #43026
      blueaxis
      Participant

      I tried v2c but again the result was same as v1. It was inconsistent with the other tool I mentioned. I haven’t tried version 3 so that’s something I should poke around.

    • #43027
      mambru
      Participant

      You should start learning how SNMP works and what MIBs and OIDs are

    • #43028
      rance
      Participant

      Been a while since i messed with SNMP, but try replacing your 1 at the end of your command with a .

Viewing 5 reply threads
  • You must be logged in to reply to this topic.

Copyright ©2022 Caendra, Inc.

Contact Us

Thoughts, suggestions, issues? Send us an email, and we'll get back to you.

Sending

Sign in with Caendra

Forgot password?Sign up

Forgot your details?