Need some help using PuTTy.

Viewing 10 reply threads
  • Author
    Posts
    • #6140
      H4TT1fn4TT
      Participant

      I am trying to use PuTTy in Windows to connect to my Backtrack box that I got running in Oracle VM Virtual Box. However when I try to connect with the IP that is given to the box I get an error.

      Network error: Connection reused.

      Any ideas on what I should try to get it to work?

      * started the SSH server in Backtrack, still same error.

    • #38440
      mesho
      Participant

      firstly, did you try to ping your backtrack box?

      if it’s not pingable! then i think the issue with backtrack firewall try to disable it and it will fix your issue.

      if neither methods work i think the issue with the network configuration in VMware.

      😛

    • #38441
      H4TT1fn4TT
      Participant

      As far as I am aware the firewall is disabled in Backtrack by default.

      I will look into the other two thing.

    • #38442
      Data_Raid
      Participant

      I’ll ask the obvious first, just to be sure 🙂

      Have you generated your SSH keys with the ” sshd-generate ” command?
      Can you successfully start SSHD ” /etc/init.d/ssh start ” ?
      Can you confirm that SSHD is listening ” netstat -antp | grep sshd ” ?

    • #38443
      TheXero
      Participant

      Most likely that the SSH Daemon is not running

      If it is, you’re likely to have a networking issue

      What network adapter type have you given it? Host only? Bridged etc

    • #38444
      hell_razor
      Participant

      You need to generate ssh keys in BackTrack then restart the service.

      service ssh stop

      /usr/bin/sshd-generate

      service ssh start

    • #38445
      H4TT1fn4TT
      Participant

      I did create a certificate and started the SSH server (I should had mentioned that, sorry).

      @TheXero wrote:

      What network adapter type have you given it? Host only? Bridged etc

      I am pretty new to it all and am trying to learn from scratch you could say. Sad to say knowing that, that I have no idea how to check up what you just asked. If there is a default I left it at that.

    • #38446
      hell_razor
      Participant

      Also, the network is not turned up when you start backtrack.  Perhaps that is missing?

      service network start

      or

      ifconfig eth0 && dhclient3 eth0

    • #38447
      rattis
      Participant

      @H4TT1fn4TT wrote:

      I did create a certificate and started the SSH server (I should had mentioned that, sorry).

      @TheXero wrote:

      What network adapter type have you given it? Host only? Bridged etc

      I am pretty new to it all and am trying to learn from scratch you could say. Sad to say knowing that, that I have no idea how to check up what you just asked. If there is a default I left it at that.

      I think the default is to nat the box. What you need to do, is shut the backtrack box down. Go into the window where you would select and start it. You’ll want to go to the settings > network tab, and change that to bridge, and then assign it to one of the ethernet cards you want to use (one of the actual ones on the windows box).

      Might have some of the steps above wrong, going from memory without access to VirtualBox from where I am.

      But you’ll have to shut the BT box down to make the changes.

      Options are NAT, Bridged, HOSTonly (or something like that). There may be a disabled option too… but as I said, I can’t remember exactly and can’t check.

      The documents used to be pretty good at that back before it was Oracle’s, I don’t know how they are now.

    • #38448
      H4TT1fn4TT
      Participant

      @hell_razor wrote:

      Also, the network is not turned up when you start backtrack.  Perhaps that is missing?

      No, but thanks for trying to help (/etc/init.d/networking start, was the one you where looking for).  😉

      Thanks Chrisj, I will look into it.

    • #38449
      hell_razor
      Participant

      @H4TT1fn4TT wrote:

      @hell_razor wrote:

      Also, the network is not turned up when you start backtrack.  Perhaps that is missing?

      No, but thanks for trying to help (/etc/init.d/networking start, was the one you where looking for).  😉

      Thanks Chrisj, I will look into it.

      While I used network instead of networking as it should be:

      service networking start is pretty much the same thing as /etc/init.d/networking start and that is definitely not the same thing as:

      ifconfig eth0 up && dhclient3 eth0

      which I prefer since I do not need wicd started nor an attempt to bring up the entire plethora of network interfaces possible with bringing up networking as a whole (easier than modifying the interfaces since I change interfaces a lot depending on what I am doing).

Viewing 10 reply threads
  • You must be logged in to reply to this topic.

Copyright ©2022 Caendra, Inc.

Contact Us

Thoughts, suggestions, issues? Send us an email, and we'll get back to you.

Sending

Sign in with Caendra

Forgot password?Sign up

Forgot your details?