I cant install MSF on my ubuntu 12.10

This topic contains 14 replies, has 4 voices, and was last updated by  cyber.spirit 7 years ago.

  • Author
    Posts
  • #8063
     cyber.spirit 
    Participant

    Hi there,
    For some reasons i can’t use backtrack for a month and i decided to use ubuntu 12.10. i downloaded the “metasploit-latest-linux-installer.run” file and i did these commands:

    sudo su
    chmod +X metasploit-latest-linux-installer.run
    sudo ./metasploit-latest-linux-installer.run

    but it gives me command not found error can you help me?? i dont wannna install it online using apt-get command.

  • #51107
     m0wgli 
    Participant

    Have you tried it without the sudo su step?

  • #51108
     cyber.spirit 
    Participant

    @m0wgli wrote:

    Have you tried it without the sudo su step?

    Yes i did that but i got the same error

  • #51109
     hayabusa 
    Participant

    What command is it barking about?

    Also, if you’re already sudo su, why are you sudo’ing the final command?

  • #51110
     RoleReversal 
    Participant

    Could be many things, have you checked all the usual candidates? download checksums? File/user permissions? etc?

    Possible stupid (and/or insulting – not intended) question, you are in same directory as the *.run installer when issuing the ./*.run command?

    I’m running on 12.10 and MSF running perfectly my end…..

  • #51111
     cyber.spirit 
    Participant

    @andrew Waite wrote:

    Could be many things, have you checked all the usual candidates? download checksums? File/user permissions? etc?

    Possible stupid (and/or insulting – not intended) question, you are in same directory as the *.run installer when issuing the ./*.run command?

    I’m running on 12.10 and MSF running perfectly my end…..

    If i can rename it del it and make it executable through terminal it means i have enough perms and my path is correct im not new on linux

  • #51112
     cyber.spirit 
    Participant

    @hayabusa wrote:

    What command is it barking about?

    Also, if you’re already sudo su, why are you sudo’ing the final command?

    Yeah ur right i’m wondering too however i used sudo su but if i dont use sudo for my command it gives me perm denied error

  • #51113
     hayabusa 
    Participant

    Try this (if you haven’t already):

    http://www.johanpaul.com/blog/2012/02/sudo-script-sh-command-not-found-on-ubuntu/

    Edit –

    The actual ‘fix’ from that post:

    “Update: Seem Björn’s blog is down, so I’ll post the solution here. Put the following line to your $HOME/.bashrc file:

    alias sudo=’sudo env PATH=$PATH $@’
    And the run source $HOME/.bashrc (this will not be necessary on subsequent boots or starts of the terminal). You should again be able to run your scripts with sudo.

    This will enable the fix only for me, as I put the alias in my .bashrc file, so it’s not even a terrible security risk. And that’s fine.”

  • #51114
     RoleReversal 
    Participant

    @cyber.spirit wrote:

    im not new on linux

    Hence my attempted caveat. But you are having problems, and you did ask for help; which I was trying to provide. Won’t bother next time.

  • #51115
     cyber.spirit 
    Participant

    hayabusa the problem was so stupid!
    When i used chmod +x it won’t make executable. I just used chmod 777 and msf is installing now!!!

  • #51116
     hayabusa 
    Participant

    OK, well, with regard to my other reply (the thread about the paths), it might be something to keep in mind.

    To THAT end, here’s a bit more about that issue:

    http://askubuntu.com/questions/146869/why-does-sudo-not-add-roots-path-with-ubuntu-12-04

    Glad you got it working.   🙂

    (again) –

    I’d be curious if the “sudo ./metasploit-latest-linux-installer.run” would’ve worked properly, if you HADN’T already been sudo su, without the aformentioned PATH workarounds. Maybe I’ll test it out, if time permits (not likely, the way this morning’s shaking out.)  Anyway, again, glad it works.

  • #51117
     m0wgli 
    Participant

    I just noticed in your first post that you had a capital X which won’t change it, but your last post has a lowercase x. Just interested to know, do you still get that problem if use a lowercase x?

  • #51118
     hayabusa 
    Participant

    @m0wgli wrote:

    I just noticed in your first post that you had a capital X which won’t change it, but your last post has a lowercase x. Just interested to know, do you still get that problem if use a lowercase x?

    …and then there’s that…

  • #51119
     cyber.spirit 
    Participant

    @andrew Waite wrote:

    @cyber.spirit wrote:

    im not new on linux

    Hence my attempted caveat. But you are having problems, and you did ask for help; which I was trying to provide. Won’t bother next time.

    Andrew man your not bothering me i just wanted to mention my situation. please don’t be sad of my reply.

  • #51120
     cyber.spirit 
    Participant

    @m0wgli wrote:

    I just noticed in your first post that you had a capital X which won’t change it, but your last post has a lowercase x. Just interested to know, do you still get that problem if use a lowercase x?

    No No it was just wrong type here i know x must be lower case and i typed lower case in ternminal but it didn’t work!!!!!!!!!!!!!!!!!!!!!!!!!!1

You must be logged in to reply to this topic.

Copyright ©2019 Caendra, Inc.

Contact Us

Thoughts, suggestions, issues? Send us an email, and we'll get back to you.

Sending

Sign in with Caendra

Forgot password?Sign up

Forgot your details?